Gadgets not working

This forum is for users to submit their own gadgets to the community
Post Reply
SAS
Vectric Apprentice
Posts: 2
Joined: Sun Aug 21, 2016 1:17 pm
Model of CNC Machine: xcarve

Gadgets not working

Post by SAS »

Hi

I am new to Vectric and was hoping someone could lend a helping hand.
I am currently trial testing the new Aspire 8.5 on a project similar to Wikihouse and Facit Homes. So far its been a real solid program to use.

It seems though I am facing a problem that some may already have encountered.
When the gadget exe files are installed and ran (even as administrator) the product selection box is empty and the file size is zero. Nothing happens.
The files are in the right folder and appear in the program:

users/public/public documents/vectric files/gadgets/aspire 8.5

There are some LUA zipped files floating around on the forum for example the spiral gadget. I have downloaded them and they works fine as an LUA file.
Not sure if the issue lies within the gadget itself or is something I am doing/not doing.

The process has been lightning fast with a great deal of automation up until this point.
But we have almost come to grinding stop as we have hundreds of components and could make great use of the gadgets.

If anyone could please post the following gadget LUA zip files, I would greatly appreciated it :!:

Dogbone filleter gadget
Apply template to all sheets gadget


Many Thanks

LittleGreyMan
Vectric Apprentice
Posts: 918
Joined: Fri May 15, 2015 1:10 pm
Model of CNC Machine: 3 axis small size machine
Location: France

Re: Gadgets not working

Post by LittleGreyMan »

Hi,

AFAIK, gadgets don't work with the trial version.
Best regards

Didier

W7 - Aspire 8.517

SAS
Vectric Apprentice
Posts: 2
Joined: Sun Aug 21, 2016 1:17 pm
Model of CNC Machine: xcarve

Re: Gadgets not working

Post by SAS »

Hi AFAIK

Thanks for replying.

Someone has posted an LUA file zipped it worked fine for me.
I have installed the spiral gadget LUA file with no issues.

At this point the software is working well for us but I don't wan to purchase the licence just to try out the gadgets.
If it worked with the spiral LUA file then I am hoping it will work with the dogbone gadget and apply template to all files gadget.
Which is what we really need at this point.

Regards,

PaulRowntree
Vectric Wizard
Posts: 1687
Joined: Sun Oct 24, 2010 7:28 pm
Model of CNC Machine: homebuilt 4'x2' (Mach3+G540)
Location: Guelph, Ontario
Contact:

Re: Gadgets not working

Post by PaulRowntree »

What do you mean that the spiral Lua code 'works fine as Lua code'? As LGM said, gadgets are not supported in the trial versions. Some Lua code doesn't need an html interface, and might run outside the Vectric environment, but I doubt it would do anything useful.

You should decide to buy/not buy the base program on its own merits (and most here think the merits are strong). Any added value that the gadgets can provide are bonuses.
Paul Rowntree
WarpDriver, StandingWave, Topo and gadgets available at PaulRowntree.weebly.com

LittleGreyMan
Vectric Apprentice
Posts: 918
Joined: Fri May 15, 2015 1:10 pm
Model of CNC Machine: 3 axis small size machine
Location: France

Re: Gadgets not working

Post by LittleGreyMan »

I agree with Paul.

Gadgets generally work fine and are maintained, so you shouldn't have any issue.

If you don't mind sharing your test file, post it in a DropBox, give instructions, and someone will probably quickly run a test.

Last point: automatic dog bones is probably very useful, but unless you have a lot of dog bones and non repetitive projects (which can quickly lead to huge numbers), placing them manually is very quick with Aspire.
Best regards

Didier

W7 - Aspire 8.517

User avatar
Adrian
Vectric Archimage
Posts: 10128
Joined: Thu Nov 23, 2006 2:19 pm
Model of CNC Machine: ShopBot PRS Alpha 96x48
Location: Surrey, UK

Re: Gadgets not working

Post by Adrian »

The Apply Templates gadget works perfectly. I use it every day.

Post Reply