Suppress Z axis moves in PP output

Post Reply
BR928S4
Posts: 15
Joined: Sat Aug 18, 2007 10:39 pm
Location: Baton Rouge, LA

Suppress Z axis moves in PP output

Post by BR928S4 »

I am building a scanner that only has X and Y axis. It uses GRBL PP.
Is there a way to suppress all Z axis commands in the output?
(Any Z axis commands causes the movement to pause between tool paths)
I have tried to search the forum but have come up empty.
Any ideas?

bravesoul
Vectric Apprentice
Posts: 198
Joined: Thu Sep 11, 2014 8:53 pm
Model of CNC Machine: ShopBot PRT ALPHA 48"x96"
Location: Cleveland, TN
Contact:

Re: Suppress Z axis moves in PP output

Post by bravesoul »

Have you opened up the Grbl_inch (or mm) .pp and possibly commented or removed all Z references: located here C:\ProgramData\Vectric\Aspire\V10.0\PostP (just look for you Vectric product, mine is Aspire)?

Joe

User avatar
Adrian
Vectric Archimage
Posts: 10240
Joined: Thu Nov 23, 2006 2:19 pm
Model of CNC Machine: ShopBot PRS Alpha 96x48
Location: Surrey, UK

Re: Suppress Z axis moves in PP output

Post by Adrian »

Look on the Help menu in Cut2D/VCarve/Aspire. There is a guide to editing post processors there which will give you all the info you need to create/modify a post processor without z moves.

To get to the PostP folder use the Open Application Data folder option on the File menu.

wb9tpg
Vectric Craftsman
Posts: 147
Joined: Tue Sep 04, 2018 2:49 pm
Model of CNC Machine: Shapeoko 3 XL

Re: Suppress Z axis moves in PP output

Post by wb9tpg »

Look at the Post Processors offered on the J-Tech Photonics site. They have NO-Z versions of the Post Processors for their lasers. You can learn by looking at them

Post Reply