Laguna IQ help, Z Axis ignores feedrates in Gcode?

Post Reply
suade907
Posts: 41
Joined: Wed Aug 03, 2011 5:07 am
Model of CNC Machine: CNCRP 48x48
Location: Manhattan, Illinois

Laguna IQ help, Z Axis ignores feedrates in Gcode?

Post by suade907 »

Hi guys, anyone on here have a Laguna IQ or a machine with a RichAuto A11E control. I have a problem where my machine has all z axis feed rates overridden by the set work parameters speeds when you run a program. All X/Y feed rates are operating at the gcode programmed federates. There has to be a setting not turned on in the control. I have enabled under auto pro setup/ G code setup to F read = ReadF. This was not turned on by default. I'm using the vectric laguna IQ HHC post. How do I get the control to operate z axis feedrates at the speeds in the gcode?

Thanks so much. Here is my Gcode:
(Filename: test 1)
N10M03S18000
N20G00X0.000Y0.000Z19.050
N30G00Z5.080
N40G1Z-25.400F254.0
N50G1Y203.200F2540.0
N60G1X127.000
N70G1Y0.000
N80G1X0.000
N90G00Z19.050
N100G00Z19.304
N110M05
N120M30
%

It obviously has a 254.0 feed rate for the Z-axis plunge move but no matter what when the program runs it uses the settings in the set work parameters. For those not familiar with this control when you chose to run a program there is a set program parameter screen that you select a work speed, a rapid speed, and a fall down which is the % of work speed the Z-axis runs at and there is a scale setting I believe as well. If there are no feed rates in the gcode or the F read setting in the control is set to ignore F the control defaults to these. I have enabled in the control the setting that enables feed rates from the gcode but for some reason the control ignores the Z-axis feedrates and uses the set work parameter settings.

If anyone can tell me what the setting is I have to change you will be my idol. I've filed a ticket with Laguna but I'm learning they are very slow to respond.

suade907
Posts: 41
Joined: Wed Aug 03, 2011 5:07 am
Model of CNC Machine: CNCRP 48x48
Location: Manhattan, Illinois

Re: Laguna IQ help, Z Axis ignores feedrates in Gcode?

Post by suade907 »

Hi Guys, I figured it out. When using feed rate in the gcode you have to have the fall down set to 1 to utilize the full speed of the gcode feed rate. This is why mine wasn't reading the correct feed rate. What made it more confusing is my machine is set to have it's slowest Z axis feedrate to 100mm so it wasn't showing 10% of 254 and that made me even more confused. Thanks for the help, Hopefully this helps someone else.

Post Reply