PP results not working on 6090 cnc

This forum is for general discussion about Aspire
Post Reply
awesome
Posts: 2
Joined: Tue Jan 29, 2019 9:46 am
Model of CNC Machine: CNC 6040

PP results not working on 6090 cnc

Post by awesome »

Group, I need your help with either a correction in Aspire 10, pp file, or RichAuto B58 dsp settings.

Background:
Based on feedback from the Vectric and Avid team in Denver show, I decided to do an upgrade from RichAuto A11 3axis (x,y,z, rotary x wrap around y) to B58 4axis (x,y,z,a with additional drive) on Chinese 6090 CNC. A axis (rotary) pulse set to 13.3 pluses/mm for 0.5 deg turn on rotary. Used Axiom Elite pp for Aspire b/c they use the same DSP (took the line # feature out). Confirmed DSP is able to move all axis via the pad.

Created a test file output from Aspire using a rotary project with a simple wrap around on-line profile path to check 360 deg rotary turn:

G91G28X0Y0Z0
G40G17G80G49
T1M6
G90G54
G0X0Y0M3
G0A0.000Y0.000S16000
G00A0.000Y0.949Z5.080
G1Z-3.000F254.0
G1A360.000F762.0
G00Z5.080
G28G91Z0
G49H0
G28X0Y0
M05
M30


When run on the RichAuto B58DSP, the spindle fires up, goes down, but then goes back up without doing the rotation. I do not see anything wrong with the code. Ran a another file with a spiral that showed 4.25 turns based on spacing and Y distance but when I run it, Y distance is met but A only turns about 90 deg.

So what am I missing?

Thank you in advance for any guidance that can get me past this hurdle.

Asim

User avatar
martin54
Vectric Archimage
Posts: 5736
Joined: Fri Nov 09, 2012 2:12 pm
Model of CNC Machine: Gerber System 48,Denford Triac Modified
Location: Crossgates, Scotland

Re: PP results not working on 6090 cnc

Post by martin54 »

I don't do rotary myself but from my understanding you need to use a Post Processor that is set up for rotary work. Is the PP you are using one suitable for rotary work? On the PP list I believe most of them have "wrap" in the title & the axis to wrap so either wrap x or wrap y
Sure one of the board experts on Rotary work will be able to give you a better answer but this might get you started :lol: :lol:

CutnCreate
Vectric Apprentice
Posts: 5
Joined: Thu Oct 29, 2020 11:28 am
Model of CNC Machine: TigertecTR510 ATC

Re: PP results not working on 6090 cnc

Post by CutnCreate »

awesome wrote:
Fri Jun 12, 2020 3:31 am
Group, I need your help with either a correction in Aspire 10, pp file, or RichAuto B58 dsp settings.

Background:
Based on feedback from the Vectric and Avid team in Denver show, I decided to do an upgrade from RichAuto A11 3axis (x,y,z, rotary x wrap around y) to B58 4axis (x,y,z,a with additional drive) on Chinese 6090 CNC. A axis (rotary) pulse set to 13.3 pluses/mm for 0.5 deg turn on rotary. Used Axiom Elite pp for Aspire b/c they use the same DSP (took the line # feature out). Confirmed DSP is able to move all axis via the pad.

Created a test file output from Aspire using a rotary project with a simple wrap around on-line profile path to check 360 deg rotary turn:

G91G28X0Y0Z0
G40G17G80G49
T1M6
G90G54
G0X0Y0M3
G0A0.000Y0.000S16000
G00A0.000Y0.949Z5.080
G1Z-3.000F254.0
G1A360.000F762.0
G00Z5.080
G28G91Z0
G49H0
G28X0Y0
M05
M30


When run on the RichAuto B58DSP, the spindle fires up, goes down, but then goes back up without doing the rotation. I do not see anything wrong with the code. Ran a another file with a spiral that showed 4.25 turns based on spacing and Y distance but when I run it, Y distance is met but A only turns about 90 deg.

So what am I missing?

Thank you in advance for any guidance that can get me past this hurdle.

Asim
Hi Awesome. I am also having trouble with the same controller on a very similar machine. I have asked Vectric directly about the possibility of making a pp for this controller as we are an agent of theirs. Ill reply again if anything comes of it. In the meantime I hope someone else posts the solution first because its making me tear my hair out.!!

Post Reply