Import CAD drawing toolpathing issue

This forum is for general discussion about Aspire
Post Reply
stlcnc
Posts: 3
Joined: Thu Feb 08, 2018 6:51 am
Model of CNC Machine: CNC router parts pro 60120

Import CAD drawing toolpathing issue

Post by stlcnc »

Recently imported a CAD drawing in DXF from Turbo cad. The lines were segmented, so I joined them. I guess they were off a little and the joining caused them to moved distances.
It cut about .015 off from what it was supposed to be. Making mdf template for woodworker. Template will flex that much, but whatever. He insisted I not change hi drawing in anyway. So I tried to toolpath his segmented drawing. The toolpath was set for profile outside cut. The right side cut outside, the left cut on the inside in the radius. In the squared section, it cut the opposite. So it is jagged. I recreated his drawing best I could within a couple thou, which I know will cut right.
Attached is the file.
left unit is my recreate
middle is their drawing with joined vectors
right is original untouched drawing.

Can you tell me why the original is toolpathing wonky. My guess is starting point of the lines when drawn, or got flipped around so it sees it as the outside. or something like that.
Attachments
glazeview original with redo.crv3d
(708 KiB) Downloaded 16 times

User avatar
martin54
Vectric Wizard
Posts: 4870
Joined: Fri Nov 09, 2012 2:12 pm
Model of CNC Machine: Gerber System 48,Denford Triac Modified
Location: Crossgates, Scotland

Re: Import CAD drawing toolpathing issue

Post by martin54 »

With open vectors the inside or outside of the line is determined by the starting point of the vector, if you find you need to change which side of the line the profile is cutting on you just need to change the start point from one end of the vector to the other, the green node indicate the start point :lol: :lol:

User avatar
adze_cnc
Vectric Apprentice
Posts: 913
Joined: Sat Jul 27, 2013 10:08 pm
Model of CNC Machine: AXYZ 4008
Location: Vancouver, BC, Canada

Re: Import CAD drawing toolpathing issue

Post by adze_cnc »

How did you join the vectors? Did you use "Join / Close - vectors by moving end points to common point"? If so how about "Join / Close - vectors with a straight line" instead?

The former would cause the "movement" you mentioned making the template not right.

Post Reply