Version 9 problem

This forum is for general discussion about Aspire
stanv77
Vectric Apprentice
Posts: 62
Joined: Sat Apr 25, 2015 6:41 pm
Model of CNC Machine: pdj cnc

Version 9 problem

Post by stanv77 »

Has anyone else had problems with the latest upgrade
I upgraded and I have had nothing but slow performance
since

User avatar
Rcnewcomb
Vectric Wizard
Posts: 3947
Joined: Fri Nov 04, 2005 5:54 am
Model of CNC Machine: GCnC/WinCNC
Location: San Jose, California, USA
Contact:

Re: Version 9 problem

Post by Rcnewcomb »

No issues here
- Randall Newcomb
10 fingers in, 10 fingers out
another good day in the shop

User avatar
Adrian
Vectric Archimage
Posts: 10555
Joined: Thu Nov 23, 2006 2:19 pm
Model of CNC Machine: ShopBot PRS Alpha 96x48
Location: Surrey, UK

Re: Version 9 problem

Post by Adrian »

No problems here and I don't recall anyone else reporting an issue like that on here either.

Which operations are you finding slower than previously? Have you checked Task Manager while Aspire is running?

User avatar
lboss
Posts: 6
Joined: Fri Jan 31, 2014 3:18 pm
Model of CNC Machine: 4x8 MotionMaster, Patriot, FAGOR Control
Location: Denver, Colorado

Re: Version 9 problem

Post by lboss »

Running good for me.
Lynn Boss

vip-klaus
Vectric Apprentice
Posts: 57
Joined: Sat Jan 12, 2013 1:01 pm
Model of CNC Machine: Wabeco F1410 LF-C HS; Sorotec AL1110
Location: Wurmberg, Germany

Re: Version 9 problem

Post by vip-klaus »

Same problem like stanv77 here. Version 9.514 shows extremely slow reaction after each mouseclick. It's no more fun to work with.

Any ideas?

Klaus

User avatar
Adrian
Vectric Archimage
Posts: 10555
Joined: Thu Nov 23, 2006 2:19 pm
Model of CNC Machine: ShopBot PRS Alpha 96x48
Location: Surrey, UK

Re: Version 9 problem

Post by Adrian »

Is that all the time or with a job loaded? Toolpaths? 3D components etc?

Have you checked task manager to see the memory usage, cpu load of tasks running?

vip-klaus
Vectric Apprentice
Posts: 57
Joined: Sat Jan 12, 2013 1:01 pm
Model of CNC Machine: Wabeco F1410 LF-C HS; Sorotec AL1110
Location: Wurmberg, Germany

Re: Version 9 problem

Post by vip-klaus »

I just did some tests: problem occures at 2-sides jobs.

- create a new 2-sided job
- create one single circle both on the top- and the bottom-side
- create a profile toolpath on both sides

Thats all. Calculating and preview lasts at least 10 times longer than before.

No problem with one-sidesd jobs.


Klaus

User avatar
Adrian
Vectric Archimage
Posts: 10555
Joined: Thu Nov 23, 2006 2:19 pm
Model of CNC Machine: ShopBot PRS Alpha 96x48
Location: Surrey, UK

Re: Version 9 problem

Post by Adrian »

Yes, I'm seeing that as well now you've posted the steps.

rig gap
Posts: 45
Joined: Fri Jan 03, 2014 1:00 am
Model of CNC Machine: Home built aluminum and steel 3 X 4 CNC
Location: Charlotte, NC

Re: Version 9 problem

Post by rig gap »

Getting the same delays...I thought at first it was my computer, but after some trials, I'm convinced it's caused by the newest patch.

Tailmaker
Vectric Wizard
Posts: 306
Joined: Sun Jun 16, 2013 4:40 am
Model of CNC Machine: Home Built 4-axis Router
Location: Fort Collins, CO

Re: Version 9 problem

Post by Tailmaker »

Hm...I tried and did not see a difference. Same circle size at same center position an both sides.
Toolpath calculation takes a fraction of a second one sided or two sided.
Can somebody post the offending file?

User avatar
highpockets
Vectric Wizard
Posts: 3200
Joined: Tue Jan 06, 2015 4:04 pm
Model of CNC Machine: PDJ Pilot Pro

Re: Version 9 problem

Post by highpockets »

I'm seeing the same problem, doing a double sided job, but only a circle on front side.
Single sided job doesn't have the same delays.
Running 9.514
John
Maker of Chips

User avatar
watsonswords
Posts: 21
Joined: Tue Jul 09, 2013 5:01 am
Model of CNC Machine: PDJ Pilot Pro
Location: Bonney Lake, WA USA
Contact:

Re: Version 9 problem

Post by watsonswords »

I just spoke to StanV on the phone and I do not have the problem on double-sided. Still quick here with the latest upgrade.
Tom Watson www.signsinwood.com

User avatar
Adrian
Vectric Archimage
Posts: 10555
Joined: Thu Nov 23, 2006 2:19 pm
Model of CNC Machine: ShopBot PRS Alpha 96x48
Location: Surrey, UK

Re: Version 9 problem

Post by Adrian »

Tailmaker wrote:Hm...I tried and did not see a difference. Same circle size at same center position an both sides.
Toolpath calculation takes a fraction of a second one sided or two sided.
Can somebody post the offending file?
This file takes about five seconds to switch sides for me and some other operations (such as going to preview) take far longer than they would normally. Just loading it into a new session takes a while.
Attachments
Slow File.crv3d
(215.5 KiB) Downloaded 53 times

mohamed
Vectric Staff
Posts: 108
Joined: Wed Jul 19, 2017 11:59 am
Model of CNC Machine: Craft CNC DS1

Re: Version 9 problem

Post by mohamed »

I think we got to the bottom of this now. The issue is mainly to do with the simulation resolution and not project dependent. You'd notice a slowdown in opening any project, opening preview form, flipping sides, (x2 if it's two-sided). The slowdown is less noticeable with lower simulation resolutions.

Our apologies for the inconvenience! We're working on a fix and will be issuing a update as soon as possible.

Mohamed
++++++
Mohamed
-----------

4DThinker
Vectric Wizard
Posts: 1388
Joined: Sun Sep 23, 2012 12:14 pm
Model of CNC Machine: CNC Shark Pro, Probotix Meteor 25" x 50"

Re: Version 9 problem

Post by 4DThinker »

Thanks Mohamed. My PC with the update also shows a noticeable delay on any step of making a toolpath when the project is a 2-sided job. Once the PC responds things proceed at a normal pace. As if the code now stops to think for awhile before deciding to continue. I'll put off updating the install at work until a newer update is available.

Post Reply