Real novice looking for a post_base error fix

This forum is for general discussion regarding VCarve Pro
Post Reply
Scott A Vandenbos
Posts: 2
Joined: Sat Feb 13, 2021 11:04 pm
Model of CNC Machine: Shark SD110

Real novice looking for a post_base error fix

Post by Scott A Vandenbos »

First - REAL novice to Vcarve and not real knowledgeable about the software's guts.
Finally upgraded to 11 from 10.5, Should have left it alone but Its a newer version right? I get a Post_base error that is no longer supported. I found 'help' on this forum but it might as well be in a foreign language. Is there a novice (simple - real simple) way to fix this error? Haven't used the Shark for 3-4 months but have a need now and would like this corrected. YOU'D think that updating would FIX issues not create them. Very frustrated.

User avatar
AboveCreations
Vectric Apprentice
Posts: 85
Joined: Wed Sep 01, 2021 8:56 pm
Model of CNC Machine: Chinese 6040
Location: NC

Re: Real novice looking for a post_base error fix

Post by AboveCreations »

I think if anyone is going to help, they will need more information than just a post base error. I personally don't recall that error. But searching is showing it might be something to do with your post processor being out of date. After you make your toolpaths, you select a post processor for your machine. Perhaps there is a newer one for your machine? Shark folks may know.

Otherwise, tell us what you are doing when you get that error. Screen captures sometimes help. A copy of the .crv file helps if that is allowed.

User avatar
Adrian
Vectric Archimage
Posts: 12547
Joined: Thu Nov 23, 2006 2:19 pm
Model of CNC Machine: ShopBot PRS Alpha 96x48
Location: Surrey, UK

Re: Real novice looking for a post_base error fix

Post by Adrian »

When you get the pop up warning box displayed make a note of the file name. It will start with C:\ProgramData\Vectric....

Now go to the File menu in VCarve and choose Open Application Data Folder. That will open a standard windows file explorer window.

Double click the My_PostP folder. You should now be able to see a file that matches the name at the end of the path you noted earlier. Delete that file and close VCarve.

Now when start VCarve you shouldn't get that warning displayed anymore.

Depending on how you setup VCarve 11 when you first installed it you might need to go through the kickstart process again which you can do from the Help menu.

Scott A Vandenbos
Posts: 2
Joined: Sat Feb 13, 2021 11:04 pm
Model of CNC Machine: Shark SD110

Re: Real novice looking for a post_base error fix

Post by Scott A Vandenbos »

These replies and a quick email to support. I got it running! Had to delete the .pp files (moved them - to afraid to delete) then restart, then select machine type etc. Simple now I know what to do. Thanks SO much for the replys! This was my first time using the forum. Likely I'll be back. Thanks everyone!

Jan.vanderlinden
Vectric Wizard
Posts: 478
Joined: Wed Sep 28, 2016 10:19 pm
Model of CNC Machine: Xcarve
Location: Columbus Ohio

Re: Real novice looking for a post_base error fix

Post by Jan.vanderlinden »

Its a rule...
You HAVE to come back to show us your projects.. :D

Welcome aboard.
“I've learned so much from my mistakes, I'm thinking of making a few more”

Post Reply