Using ASPIRE’S Two Rail Sweeps to Sculpt a House Shape
Introduction
In creating a sign for a historic cabin I wanted the focus to be on the original cabin itself since in rebuilding it the
look was changed. Thus I wanted the cabin model to “stand out” both figuratively and literally. When drawing an
object such as a house or barn one typically obtains perspective in 2D space by using a vanishing or focal point to
make the objects appear to fade or taper away from the viewer. Hence the visual lines defining the shape of the
object such as the side corners which are really parallel are drawn slanted such that they meet at that focal point. In
3D relief carving we have the additional tool of using actual depth to add to the illusion. In the steps below I will
show how I used the Aspire Two Rail Sweeps to add depth relief to the log cabin component by making the corner
closest to the viewer (where front meets side) the high point with the front, sides, and roof all sloping away from that
focal perspective. I also added depth by defining some roof overhang and fascia.
The steps below assume you have gone through James Booth’s excellent tutorials on the Aspire CD and are fairly
comfortable navigating within Aspire. Steps I – IV basically repeat those processes found in the tutorials. Step V
introduces an added level of complexity by making two complex shapes match up to each other. This technique
showcases the precision that Aspire is capable of.
In Step I we set up an Aspire job by defining the material, setting up layers, and importing the bitmap to be modeled.
Step II creates a series of closed vectors on different layers that will be used to outline the borders of the 3D shapes.
Step III creates a texture component out of the bitmap. Step IV creates and uses rail sweeps to form a shape that
defines the depth of the front and side walls of the cabin as well as creating the overhang and fascia elements. In
Step V we design and create a roof shape that attaches perfectly to the wall shapes and in Step VI we create the final
components.
The first picture shows the grey scale bitmap image of the log cabin being modeled. It has been cleaned up using a
photo editing program. If you want to use this bitmap within Aspire to follow along with the text; right-click on it,
and save it to a file for importing into Aspire. The next pictures show the 3D component perspectives created using
the procedures outlined below. (The actual Aspire .CRV3d file created is available on request).

The following conventions are used in the steps below:
• Black Bold refers to a toolset in Aspire
• Red Bold refers to a particular tool within the toolset
• Italic refers to a layer name
• Italic Bold refers to a component name

I. Setup Materials, Layers, & Bring In the Picture
Î To keep things organized and the measurement tasks simpler set your material size to 12” X 12”, 1” Thick
and set the zero point to the lower left hand corner. File>New>Job Setup (These specs can be changed
later if needed).
Î Load the bitmap picture (File>Import Bitmap)
Î Position and size the bitmap using the Edit Vectors tools. Adjust the size to near maximum width and
move it to the bottom of the 2D view (Figure 1). We will use the top area to create sweep vectors.
Î Double-click on the bitmap to bring up the Fading Slide and adjust the fading to about 50% or more so you
will be able to easily see the vectors you draw on top of it.

Figure 1

Î Create some needed layers and set a Drawing Color. Layers>Layer Control. First layer should be
renamed from default Bitmap Layer to Cabin Bitmap. Create layer 2 as Cabin Walls Outline in Dark Blue,
layer 3 as Cabin Roof Outline in Dark Green, layer 4 as Wall Sweep Rails in Red, layer 5 as Wall Sweep
Guides in Aqua, layer 6 as Roof Rails & Sweeps in purple. Layer 7 as Fascia and Overhang in Dark Red,
and Layer 8 as Measure Blocks.

Î Lock the layer that Cabin Bitmap is on so it is not inadvertently moved during construction of the vectors.
Î Hide the Layer Control box.

II. Define the Shapes of the Building Masses
 Using the Layers Control manager, turn off all layers except Cabin Bitmap (which you usually want to be
the first layer) and the layer you are working on to keep clutter down. Be careful that you have selected the
layer you want to work in within the Layer Control or you may inadvertently put your vectors on the
wrong one. In defining the major shapes for the cabin I combined the right side with the front, then defined
the roof, and finally the overhang and fascia. Make sure you use closed vector shapes for layers Cabin
Walls Outline, Cabin Roof Outline, and Fascia and Overhang.
Î In Layer Control select Cabin Walls Outline and then draw an outline (using Create Vectors tools)
around the major wall sections (front and side) as seen in Figure 2.

Î Now in Layers Control select the Cabin Roof Outline layer and draw in the roof shape as seen in Figure 3.
 Make sure the bottom roof line and the right roof line sit exactly over the front wall top lines. Zoom in to
make sure and use Edit Vectors>Node Editing to adjust!
Î Now in Layer Control choose the Fascia & Overhang layer and draw those items in (Figure 4). Again,
make sure the bottom roof line and the right roof line sits exactly over (overlap) the lines that define the top
of the fascia/overhang lines. Zoom in to make sure and use Edit Vectors>Node Editing to adjust!
Î Hide all layers except Cabin Bitmap, Cabin Roof Outline, & Cabin Walls Outline.

III. Make the Bitmap into a Texture Component
Î Select the bitmap in the 2D view & make it a component (Modelling Tools > Create a Component From
Selected Bitmap). Name the component Cabin Bitmap.

Î In Component Manager (F8), Select the Cabin Bitmap component, Copy Into Model, Uncheck the
Component and then Hide Component Manager.
Î Adjust the smoothness and depth of the bitmap component now in the 3D view (Modelling Tools>Apply
Smoothing Filter & Scale Z Height (Smooth as desired and set the height of the bitmap to .05”)
Î Make sure both Cabin Walls Outline and Cabin Roof Outline layers are on (Layer Control), In 2D view
select the roof outline and walls outline vectors and use them to trim the 3D view of the cabin (Modelling
Tools>Clear area of working model outside vectors).
Î Create a component from the modified model (Modelling Tools>Make Working Model into a
Component. Name it Cabin Texture.
Î In Component Manager (F8), Select & Delete the old bitmap component (Cabin Bitmap) you started with
& un-check (deselect) your new bitmap component (Cabin Texture) to un-display it in the 3D view, and
then Hide Component Manager.
Î Using Layers Control turn off the Cabin Roof Outline layer.

IV. Create Two Rail Sweep Vectors for Side and Front of Cabin
 What we are going to create here is a shape that has as its high point .5” on the front corner (labeled A in
the picture below); where the right side (S) slopes down to the right to 0.00” and the front side (F) slopes
down to the left to .2”. We will deal with the roof in part IV below. We are going to use the outline vectors
from the Cabin Outline layers as a basis for creating the rails.
Î Using Layers Control turn off the Cabin Walls Outline layers.
Î Make Visible the Cabin Sweep Vectors layer in Layers Control and select it to work on next.
Î Paste the shape vectors (copied from the Cabin Walls Outline layer) into the Cabin Sweep Vectors layer
(Edit>Paste).
Î Pull down some reference lines from the ruler on top of the cabin. These will be used to create the sweep
vectors. In this case I made the top and bottom reference lines about .5” apart with the middle reference
line about .10” above the bottom line as in Figure 5 below. Pull in a vertical ruler line to the corner (A) of
the building.
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 In order to do accurate work I create reference boxes (See the two rectangular boxes on the left side of
sweep vector S1) by drawing a small box that has the exact height I want. In this case use the Create
Vectors>Draw Rectangle tool and create a box Size of Width .1 with a Height of .5 and Create. Do
another one with a Height of .2”. Select those boxes and move them into the reference lines established
above and adjust the reference lines accordingly.
Î Open the Two Rail Sweep box (Modelling Tools>Two Rail Sweep).
Î Draw rails R1 and R2 following the sides and on top of the Cabin Walls Outline vector. Extend them up
into the reference lines as shown in Figure 5.

 It is important to keep the lines you will be using as Sweep Rails on top of the lines defining the shape of
the building. To check this zoom in as close. The reason this is important is twofold: To make sure that
the high point of the shape ends up on A when creating the sweep and to make sure the roof vector shape
will cleanly meet the house wall vector shape.
Î Draw the sweep shape as indicated with S1in the picture. Note that at the R1 rail S1 starts at 0.00 goes
straight up .10 inches then slopes to the high point (0.5”) where the corner (A) of the building is. Then it
slopes back down to 0.00 at rail R2. (The slope doesn’t start off at 0.00 at R1 because we need room for
the roof to slope down to 0.00).
Î Choose Two Rail Sweep under Modelling Tools>select R1,R2, and S1(reverse rail directions if
needed)>choose Add to generate 3D shape. It should resemble Figure 7. (When you select the rails and
sweep make note of the starting points (black boxes) to make sure the lines are oriented correctly).
Figure 7

Î Accept the results of the sweep if correct and Close the Two Rail Sweep box (do not make a component
yet).
Î In Layer Control turn off the rails layer and turn on the Cabin Outline layer. Choose the front/ side shape
vector and in Modelling Tools choose Clear Area of Working Model Outside Selected Vectors. The 3D
model should now be trimmed to look like figure 8:
Figure 8

Figure 9

 To make sure the corner high point is in the correct position, go into the Component Manager (F8) and
temporarily turn on the bitmap Cabin Texture component to overlay the shape. Rotate the 3D model to
make sure the bitmap fits correctly on the rail sweep. Then turn OFF the component and dismiss
Component Manager.
 In Layers Control turn ON the Fascia and Overhang layer and select it to work on. Make sure the Cabin
Walls Outline and the Cabin Roof Outline layers are also ON.
 Draw in the roof overhang area on the front and the gable fascia. Make sure they are closed vectors. It can
be one single vector if you wish. (See Figure 9). Select those vector shapes in the 2D view.
 Modelling Tools>Create Shape from Vectors>choose flat profile>set Base Height to .05”>Add. Your
3D view should look like Figure 10.

Figure 10

Figure 9

 Close the Create Shape box.

V.

Creating the Roof Sweep on Top of the Cabin Sweep
 Now we want to create the roof shape in the right place on top of the cabin walls shape created above. Up
to now most of what we have done was covered in the ASPIRE tutorials so if you experienced confusion at
any of the above steps it might help to review those tutorials. There are two new processes that will be
introduced below. The first is measuring the height of different points on the 3D model created above. The
second is using those measures to create a roof sweep shape that will align perfectly with the wall shape.
Note that the roof structure needs to start at the top of the front wall section on the overhang and slope
back. It also needs to slope from the top of the gable side down toward the left corner of the front.
Figure 12
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Î The S2 sweep pattern (See Figure 13) will start at points A2,R1 (Figure 11) and the S3 sweep will end the
sweep at points B2,R2. The dimensions & shapes of S2 and S3 are critical to how the roof “sits” on the
cabin so we need to carefully measure the height of the points that define the connection of the roof to the
walls. In the 3D view rotate the wall and zoom in on the top area. Zoom in close on the 3 areas labeled in
Figure 12 and by looking in the lower right hand corner of the screen note the Z height of those three points
– write them down. Note- your measures may differ from the ones shown below.
Î Create rail vectors R3 and R4 (Figure 13) on layer Roof Rails and Sweeps in the same manner that you
created the wall rails in Step IV by turning on the Cabin Roof Outline layer and making sure rail vectors R3
and R4 overlay the roof vector outline.
Î Create the two sweep vectors (S2 & S3) by following the same steps as in Step IV: Create measuring boxes
(3 of them) at the heights you measured for points A2 (.2526”), B2(.5500”), R2 (.2844”); draw the S2 and
S3 sweep shapes to those heights (Figure 13); making sure the starting points (black boxes) are located on
the correct part of the shapes and rails.
Î Choose Two Rail Sweep under Modelling Tools>select in order vectors R4,R3,S2 & S3 (reverse rail
directions if needed)>select Blend Linearly >choose Merge to generate the 3D shape of the roof (Figure
14).
Î Rotate the 3D view to make sure you have a nice clean fit between the two shapes. Accept the results,
Close the Two Rail Sweep.
Î Modelling Tools > Make Working Model Into a Component> Name it Building Shape.
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Î Open the Component Manager and delete all other components except Building Shape and Cabin
Bitmap Texture.
Î Clear the Working Model. Modelling Tools>Clear the Contents of the Working Model.
Î In Component Manager turn on the two components and inspect the results.
Î If there are artifacts around the edges you might want to modify the Cabin Walls Outline and Cabin Roof
Outline vectors slightly and use them to trim the shape. Remember to do this you must select each
component in Component Manager one at a time, Copy Into Model, deselect them, Hide Component
Manager, Select the wall and roof vectors in the two layers and use the Clear Area of Working Model
Outside the Selected Vectors tool in Modelling Tools. Then use the Make Working Model Into a
Component tool, Name the component, Delete the old component. Trim the next component.
Î Save the model to use in other creations such as signs. File>Save As
 Option: If you wanted your roof shape to overhang the fascia then simply make the left legs of the two
sweeps (S2 & S3) a little bit longer. This will cause the roof to be higher where it connects to the wall
shape!
Good Luck!

