first pass way too deep

This forum is for general discussion regarding VCarve Pro

Re: first pass way too deep

Postby shelkol » Mon Jul 15, 2019 1:19 am

Hi,
I played some more and limited the file to the statement that causes it to go too deep. I checked zero and it looked OK. I will get a chance to play some more tomorrow. It looks like the gcode is correct. I have to investigate carbidemotion more cause my guess is that's where the problem is or maybe the firmware.

I'd upload the file, but I've limited it to a rather small section. It is the last line below that causes it to go too deep.

T1
G17
G20
G0Z0.8000
G0X0.0000Y0.0000S12000M3
G0X0.7134Y-0.0884Z0.5000
G0Z0.2000
G1Z-0.0096F4.0
shelkol
 
Posts: 8
Joined: Sat Mar 16, 2019 6:20 pm
Model of CNC Machine: Shapeoko 3

Re: first pass way too deep

Postby Leo » Mon Jul 15, 2019 1:18 pm

shelkol wrote:I'd upload the file, but I've limited it to a rather small section. It is the last line below that causes it to go too deep.

T1
G17
G20
G0Z0.8000
G0X0.0000Y0.0000S12000M3
G0X0.7134Y-0.0884Z0.5000
G0Z0.2000
G1Z-0.0096F4.0


----------------------------------------------------------------------

G0X0.7134Y-0.0884Z0.5000 This line is instructing the machine to move to a position of "X".7143 , "Y"-.0884 and "Z" 1/2 inch above the material

G0Z0.2000 This line is instructing the machine to go to a "Z" axis position of .200 above the surface of the material in rapid

G1Z-0.0096F4.0 This line is instructing the machine to go to a "Z" axis depth of .0096 deep into the surface of the material at a feedrate of 4 inches per minute --- assuming that you are in inches

There is nothing in the gcode shown here to cause the tool to crash.

Looks like your post processor is working as it should

Couple of things to check.

Is the MACHINE CONTROL set to inches
Is the cutter being set correctly (this CAN be verified rather easily)
Imagine the Possibilities of a Creative mind

www.leosworkshop.com
User avatar
Leo
Vectric Wizard
 
Posts: 2957
Joined: Sat Jul 14, 2007 3:02 am
Location: East Freetown, Ma.
Model of CNC Machine: 1300 x 1300 x 254

Re: first pass way too deep

Postby shelkol » Mon Jul 15, 2019 2:07 pm

More info:

It is not a vcarve issue.

I was trying to rout one side of aluminum angle, so I put it on a 2x4 on top of my waste board. When working at the higher elevations, it starts too deep into the material. Just for an attempt, I tried the same exact gcode on just a peice of 3/4" pine and it worked fine. So I'm inquiring with carbide motion people to see if they think I'm crazy ( I can answer that question - 'YES' )

Thanks for all your input
Sheldon
shelkol
 
Posts: 8
Joined: Sat Mar 16, 2019 6:20 pm
Model of CNC Machine: Shapeoko 3

Re: first pass way too deep

Postby Adrian » Mon Jul 15, 2019 3:15 pm

I wonder if when the machine is moving to the starting Z position it's is exceeding the Z upper limit so the physical position of the machine is lower than it is as far as the controller is concerned (lost steps)?
Last edited by Adrian on Mon Jul 15, 2019 3:42 pm, edited 1 time in total.
User avatar
Adrian
Vectric Archimage
 
Posts: 9722
Joined: Thu Nov 23, 2006 2:19 pm
Location: Surrey, UK
Model of CNC Machine: ShopBot PRS Alpha 96x48

Re: first pass way too deep

Postby garylmast » Mon Jul 15, 2019 3:36 pm

On an older machine, I fought the problem of losing ‘Z’ height ever since I bought the machine. Although when milling, if I hit a spot that causes a bind, it would lose steps and cause it to go out of calibration. I tried everything including changing the UBS board and the stepper motor, but still had the problem. I then changed the stepper motor to an oversize, two-phase, high torque thinking my 6 HP spindle was just too heavy for the stepper motor to hold it up. I had to retrofit because it would not fit where the original went, but that solved the problem. Although occasionally the heavy spindle would lower a millimeter or so, to fix that I added a heavy spring.

Gary
Attachments
IMG_0874.jpg
(35.6 KiB) Not downloaded yet
garylmast
Vectric Wizard
 
Posts: 991
Joined: Fri Oct 23, 2009 4:03 pm
Location: Sandy, Utah

Re: first pass way too deep

Postby Leo » Mon Jul 15, 2019 4:14 pm

shelkol wrote:More info:

It is not a vcarve issue.

I was trying to rout one side of aluminum angle, so I put it on a 2x4 on top of my waste board. When working at the higher elevations, it starts too deep into the material. Just for an attempt, I tried the same exact gcode on just a peice of 3/4" pine and it worked fine. So I'm inquiring with carbide motion people to see if they think I'm crazy ( I can answer that question - 'YES' )

Thanks for all your input
Sheldon



Hmmmmmmm - I wonder

When you say "When working at the higher elevations, it starts too deep into the material." --- did you reset the tool to zero on the higher elevation material?

If YES - then reread Adrians last post - it just makes a whole lot of sense.

If you "Z" axis is hitting the top of the stroke, you can lower the "Z" above the material to .2 or .1 instead of .5 AND .03 or .05 above material before cutting
Imagine the Possibilities of a Creative mind

www.leosworkshop.com
User avatar
Leo
Vectric Wizard
 
Posts: 2957
Joined: Sat Jul 14, 2007 3:02 am
Location: East Freetown, Ma.
Model of CNC Machine: 1300 x 1300 x 254

Re: first pass way too deep

Postby shelkol » Thu Jul 18, 2019 8:29 pm

It seems that Carbide 3D isn't interested, as they got back to me a couple of ties and then just dropped it. They did mention that one possibility is that the Z axis is topping out. I did not hear this during my testing, but it seems to be the problem.

I did find out what was the issue. I did two projects of just a straight line, one in Vcarve and one in Carbide Create, The one in Carbide Create worked fine and the Vcarve one didn't. My project was 1-1/2" high and the end mill added to that. So I bottomed out the end mill, that wasn't sufficient. I then cut one leg of the angle aluminum from 1-1/2" to 1" ( which was still fine for my project ). Now the Vcarve gcode file works as well as the Carbide Create. I have made those two parts.

Now all I have to figure out is how to get Vcarve not to raise the Z axis so high during setting up the cut.

Thanks
Sheldon
shelkol
 
Posts: 8
Joined: Sat Mar 16, 2019 6:20 pm
Model of CNC Machine: Shapeoko 3

Re: first pass way too deep

Postby Adrian » Thu Jul 18, 2019 9:09 pm

Look at your Z1 and Z home (gap above material) settings in the Material Setup section at the top of the toolpath tab. They control how high the Z moves at various parts of the toolpath process.
User avatar
Adrian
Vectric Archimage
 
Posts: 9722
Joined: Thu Nov 23, 2006 2:19 pm
Location: Surrey, UK
Model of CNC Machine: ShopBot PRS Alpha 96x48

Re: first pass way too deep

Postby TReischl » Thu Jul 18, 2019 9:12 pm

shelkol wrote:
Now all I have to figure out is how to get Vcarve not to raise the Z axis so high during setting up the cut.

Thanks
Sheldon


How about paying attention to this:

Capture.JPG


All the numbers mean and do something, none of them are there just because. . . .
"If you see a good fight, get in it." Dr. Vernon Jones
User avatar
TReischl
Vectric Wizard
 
Posts: 2930
Joined: Thu Jan 18, 2007 6:04 pm
Location: Leland NC
Model of CNC Machine: 8020 Build 48X36X10 RP 2010 Screenset

Re: first pass way too deep

Postby shelkol » Fri Jul 19, 2019 11:56 am

Now that I know what the issue is, there are lots of things to do:

1. Raise the router slightly in the mount.
2. Find and adjust all those Z settings

Thanks
Sheldon
shelkol
 
Posts: 8
Joined: Sat Mar 16, 2019 6:20 pm
Model of CNC Machine: Shapeoko 3

Previous

Return to VCarve - General

Who is online

Users browsing this forum: Google [Bot] and 37 guests