G code error

This forum is for general discussion about PhotoVCarve.

G code error

Postby hfwiley » Wed Jul 17, 2019 11:50 am

Hello All.. I am running UGS platform on a E4 Bobs cnc, I keep getting an invalide G code error when trying to run the cut. I have tried with different photos and settings with in PVC, any one know what G code commands are supposed be at beginning of program or have any ideas.
hfwiley
 
Posts: 3
Joined: Wed Jul 17, 2019 2:32 am
Model of CNC Machine: bobs cnc e4

Re: G code error

Postby Adrian » Wed Jul 17, 2019 12:04 pm

Which post processor are you using? Is it the correct one for your control software? Does the company that make it have a post processor on their support pages?
User avatar
Adrian
Vectric Archimage
 
Posts: 9705
Joined: Thu Nov 23, 2006 2:19 pm
Location: Surrey, UK
Model of CNC Machine: ShopBot PRS Alpha 96x48

Re: G code error

Postby hfwiley » Wed Jul 17, 2019 2:52 pm

It is GRBL, and it may be that it is writing a tool change command that it doesn’t recognize.. will try eliminating that from code.
hfwiley
 
Posts: 3
Joined: Wed Jul 17, 2019 2:32 am
Model of CNC Machine: bobs cnc e4

Re: G code error

Postby Leo » Wed Jul 17, 2019 3:53 pm

Are you using a post processor with ATC or one without ATC. You should not be using the one with ATC -- IF -- that is the problem code.
Imagine the Possibilities of a Creative mind

www.leosworkshop.com
User avatar
Leo
Vectric Wizard
 
Posts: 2957
Joined: Sat Jul 14, 2007 3:02 am
Location: East Freetown, Ma.
Model of CNC Machine: 1300 x 1300 x 254

Re: G code error

Postby hfwiley » Wed Jul 17, 2019 5:17 pm

The T1 command in the G code was the issue, once I eliminated the tool change command it started the cut. GBRL doesn’t support tool changes so the first command was incompatable and threw the code.
hfwiley
 
Posts: 3
Joined: Wed Jul 17, 2019 2:32 am
Model of CNC Machine: bobs cnc e4

Re: G code error

Postby Adrian » Wed Jul 17, 2019 5:30 pm

You can download the grbl post processor from here - https://forum.vectric.com/viewtopic.php ... 13#p209813

It sounds like you're using the generic g-code one.
User avatar
Adrian
Vectric Archimage
 
Posts: 9705
Joined: Thu Nov 23, 2006 2:19 pm
Location: Surrey, UK
Model of CNC Machine: ShopBot PRS Alpha 96x48


Return to PhotoVCarve - General

Who is online

Users browsing this forum: No registered users and 0 guests