LinuxCnc % error message

LinuxCnc % error message

Postby ThomasScott » Thu Apr 27, 2017 2:18 am

Hi , Longtime lurker here on the forums . The active forums swayed my choice to purchase Aspire, still learning it, but ran across a strange error message a few days ago, thought it might help. I have a Probotix Nebula that uses
LinuxCnc software. Exported the toolpaths like normal, zip drive loaded them into LinuxCnc, and got this error message " File ended with no percent sign or program end" . I looked at each toolpath and there were clearly % at start and end, with the M2 commands. Ghost in the machine?, exported the toolpaths again and reloaded them, worked fine , no clue ? Drove me nuts, as this was a test of extending the Z level on my machine, was already somewhat nervous lol, last thing I needed to see was error messages. I still do not know what caused this. This may not post correctly, hard to tell format wise.
Posts: 6
Joined: Thu Jul 14, 2016 1:52 am
Model of CNC Machine: Probotix Nebula

Re: LinuxCnc % error message

Postby martin54 » Thu Apr 27, 2017 3:09 am

What was the original toolpath preview like ? if that was OK then generally the fault lies else where, are you sure you didn't remove the drive before the file had fully saved ? There are a couple of posts on the forum where people have had problems with memory sticks & the advice is always to make sure they are removed by using the windows feature to safely remove hardware :lol: :lol:

I use mach3 rather than linuxcnc but transfer the files from my design computer to the cnc control computer the same way that you do, I have a couple of memory sticks that have an inbuilt LED which flashes when the stick is active. Quite often with large files it stops & I think it has finished saving the file only for it to start flashing again :lol: :lol: :lol:
User avatar
Vectric Wizard
Posts: 4382
Joined: Fri Nov 09, 2012 2:12 pm
Location: Crossgates, Scotland
Model of CNC Machine: Gerber System 48 (modified)

Re: LinuxCnc % error message

Postby vgraves » Fri Apr 28, 2017 1:41 am

I also run LinuxCNC and have seen this error message occasionally. I think it's a Windows/Linux issue because they don't use the same characters for end of line. I transfer my NC files over a network instead of with a USB drive, but the problem still occasionally occurs, and I haven't been able to reproduce it. I just recreate the NC file, and it's usually fine the second time.

Vectric Craftsman
Posts: 117
Joined: Sat Sep 29, 2012 2:04 am
Location: Knoxville, TN
Model of CNC Machine: CNC Router Parts PRO4848 w/LinuxCNC

Re: LinuxCnc % error message

Postby ThomasScott » Tue May 02, 2017 12:34 am

Thanks guys, still not sure but like Van said , recreated the toolpaths and had no problems. I'm
a Windows guy so the LinuxCNC was completely new to me, so far I like it, but haven't had any real
problems with it yet (knock on wood, so to speak ) .

Posts: 6
Joined: Thu Jul 14, 2016 1:52 am
Model of CNC Machine: Probotix Nebula

Return to Control Software related questions

Who is online

Users browsing this forum: No registered users and 1 guest