New Problem with machining .stl files

New Problem with machining .stl files

Postby anotherdamnaccount » Thu Mar 09, 2017 12:02 am

I am calling this a new problem because we never had this problem, and then without switching anything in our toolpaths, Vectric file, CAD, post processor, etc... this problem arose. I will describe the problem below, but first will describe the backstory and refer to the problem as "problem" to keep this a little more organized. This problem happens in VCarve 8.0 and VCarve 8.5

This problem came at a very coincidental time, so we went through an entire production cycle before realizing that the problem was coming from the software.... Without getting to far into the mud about this coincidence - we were switching from WinCNC to Mach3 and back to WinCNC. We were also changing driver parameters during this time. As soon as switching back to WinCNC this problem started. We left WinCNC on Jan 1, 2016 and came back to it around Jan 12, 2016. After our return to WinCNC this problem was there. We blamed it on drive parameters as we had been changing them but I think coincidentally something happened in VCarve, maybe a software update. We continued thinking this was a driver problem until I created the same shape in AutoCAD, exported to STL and then used the information to write a file with Excel to machine the same piece. The code from Excel worked flawlessly, and the one from VCarve had the problem.

About the "problem" - We machine nested parts off sheets of 48" wide x 72" long material. Typically I can get about 9 parts on one sheet as they range in width from 3" -7" and in length from 60"-70". The parts are all thicker - up to 3/8" in the center (middle of the sheet) and thinner - around 1/8" thick on the ends. We create these 3D bodies in AutoCAD and export them as STL files to be imported into VCarve.

Our machining strategy involves using a "3D finish" toolpath followed by a "profile" toolpath to create our finished part. Within the "3D finish" toolpath we had good luck using "offset", "raster 0 degrees", and "raster 90 degrees". After Jan 12, 2016 we have only been able to make good parts using "raster 0 degrees", "offset", and "raster 90 degrees" create un-usable parts. The best I can describe the problem is the Y and Z seem out of time. Our parts all have constant slopes up and down the Y axis, with a flat area underfoot. I say the Y and Z seem out of time because The Z goes to different levels at different points on the Y when it is going up (Y+) or going down (Y-). The only work around I have found is to use the "raster 0 degrees" toolpath option. I think this works because when going side to side on the core, the Z height only changes when it retracts between passes as opposed to the strategies that dont work where the Z height constantly changed.

I hope this makes sense, I am happy to provide further clarifications, screenshots, pictures, etc....

Thanks
anotherdamnaccount
 
Posts: 2
Joined: Wed Apr 08, 2015 7:40 pm
Model of CNC Machine: ShopSabre 4896

Re: New Problem with machining .stl files

Postby M Queen » Tue Mar 21, 2017 3:30 pm

This is Mike at WinCNC. Shoot me an email mike@wincnc.net and I'll have a look at your problem. Can't promise anything but I can have a look.
Mike Queen
Microsystems World CNC (WinCNC)
https://www.youtube.com/user/cncMike304
M Queen
 
Posts: 39
Joined: Tue Jul 29, 2014 9:25 pm
Location: Buckhannon, WV, USA
Model of CNC Machine: WinCNC Hybrid

Re: New Problem with machining .stl files

Postby anotherdamnaccount » Tue Mar 21, 2017 4:25 pm

Hi Mike,

Actually I am currently working with VCarve tech support. I havent followed up in about a week though since I have been working on production and other work around the shop.

If I can't reach a conclusion working with VCarve then I will email you.

Thanks
anotherdamnaccount
 
Posts: 2
Joined: Wed Apr 08, 2015 7:40 pm
Model of CNC Machine: ShopSabre 4896


Return to Control Software related questions

Who is online

Users browsing this forum: oldiron4cnc and 2 guests