Problem with a program.

Problem with a program.

Postby DMcDonald » Wed May 10, 2017 2:16 am

So we ran this program yesterday 2x with no problems. On the 3rd try when it finished toolpath 1 and went to change tools the gantry stopped about 2 feet back and started to park the tool in the table. We had this happen a couple weeks ago on another program. That time the bit stabbed into the spoil board and actually dragged it towards the tool changer before I hit stop. We copied the vectors to a new drawing and redid the toolpaths and that fixed it but not sure of what might be causing this. I tried to upload the crv but it is over the size limit. Here is a link to the download. Thanks for any help.

https://attachment.outlook.office.net/o ... .com&isc=1
DMcDonald
Vectric Apprentice
 
Posts: 33
Joined: Tue Sep 29, 2015 5:47 am
Location: Melbourne Florida
Model of CNC Machine: Laguna Smartshop2

Re: Problem with a program.

Postby martin54 » Wed May 10, 2017 7:38 am

I am getting a 440 timeout error on your link so not sure if it's just my system or others won't be able to download the file to help as well :lol: :lol:
User avatar
martin54
Vectric Wizard
 
Posts: 3277
Joined: Fri Nov 09, 2012 2:12 pm
Location: Crossgates, Scotland
Model of CNC Machine: Gerber System 48 (modified)

Re: Problem with a program.

Postby 4DThinker » Wed May 10, 2017 12:09 pm

The only time I see similar behaviour is when the file being cut is corrupt. This can happen several ways, and depends on how the cut files get to the CNC controller.
It is critical when using USB thumb drives or portable hard drives that they are safely ejected by the PC. Pulling a drive out while it is still being written to will almost always leave you with a corrupt file. In addition it may corrupt the file allocation table on the drive so that even future file ejected safely may still end up corrupt.

On my CNC Shark where g-code travels down a USB cable to get to the controller I've had Windows time-outs and power saving strategies interrupt that data flow and leave the CNC doing something it shouldn't have.

So inspect the data flow, both as the file comes to the CNC, and while/where the controller is sending control info to the motors. A loose wire anywhere along this chain might be your culprit.

4D
4DThinker
Vectric Wizard
 
Posts: 983
Joined: Sun Sep 23, 2012 12:14 pm
Model of CNC Machine: CNC Shark Pro

Re: Problem with a program.

Postby Leo » Wed May 10, 2017 1:09 pm

Your link does not work.

I agree to safely EJECT the drive before pulling the UBS out of the main computer.

Problems like that which you describe are almost always (95%) not attributed to the vectric programs. It is almost always something else.

Corrupt files - lost steps - feeds and speeds - machine malfunction - electrical issues - or any number of or combination of things.

IF - there was something in the G-Code program the issue would be exactly the same, all the time.

SOMETIMES - the settings for Z height can be an issue. If you could show us the G-Code file we can read it and see if there are any "Z" level clearance issues.

If you could post the Vectric file we can check that.
Imagine the Possibilities of a Creative mind

www.leosworkshop.com
User avatar
Leo
Vectric Wizard
 
Posts: 2418
Joined: Sat Jul 14, 2007 3:02 am
Location: East Freetown, Ma.
Model of CNC Machine: 1300 x 1300 x 254

Re: Problem with a program.

Postby DMcDonald » Wed May 10, 2017 9:21 pm

See if this link works

https://www.dropbox.com/s/avwtywhxb1pa8 ... 9.crv?dl=0

We use a usb to transfer the cut files to the machine. The process is to save the prg to the usb, then save the crv to the usb. We then close the vcarve program and hit the eject for the usb. Once it says safe to remove device unplug it and transfer to the machine. Thanks for the replies so far. I got the job done by rewriting everything just would like to know what caused it so I can avoid the problem again.
DMcDonald
Vectric Apprentice
 
Posts: 33
Joined: Tue Sep 29, 2015 5:47 am
Location: Melbourne Florida
Model of CNC Machine: Laguna Smartshop2

Re: Problem with a program.

Postby DMcDonald » Wed May 10, 2017 9:25 pm

P APPLE(1).zip
(826.26 KiB) Downloaded 41 times


tried to add a zipped file. not sure if it will work.
DMcDonald
Vectric Apprentice
 
Posts: 33
Joined: Tue Sep 29, 2015 5:47 am
Location: Melbourne Florida
Model of CNC Machine: Laguna Smartshop2

Re: Problem with a program.

Postby Rcnewcomb » Wed May 10, 2017 10:38 pm

So we ran this program yesterday 2x with no problems. On the 3rd try

Were you running the same toolpath files each time, or were you making changes each time? I'm trying to determine if we are solving a file issue, or a machine issue.
- Randall Newcomb
10 fingers in, 10 fingers out - another good day in the shop
User avatar
Rcnewcomb
Vectric Wizard
 
Posts: 2691
Joined: Fri Nov 04, 2005 5:54 am
Location: San Jose, California, USA
Model of CNC Machine: Shopbot, CAMaster

Re: Problem with a program.

Postby ger21 » Thu May 11, 2017 1:19 am

On the 3rd try when it finished toolpath 1 and went to change tools the gantry stopped about 2 feet back and started to park the tool in the table. We had this happen a couple weeks ago on another program. That time the bit stabbed into the spoil board and actually dragged it towards the tool changer before I hit stop.



Sure sounds like an issue with the machine's tool change routine.
Gerry
ger21
Vectric Wizard
 
Posts: 862
Joined: Sun Sep 16, 2007 2:59 pm
Location: Shelby Township, MI, USA

Re: Problem with a program.

Postby highpockets » Thu May 11, 2017 1:30 am

I agree with all the above suggestions and would add, check your computer, if it's not paying 100 percent attention to the CNC it's not really controlling the CNC. This can be background apps taking up too much processor time. I had a hard drive going out on mine a year or so ago and this cause the computer to spend too much time trying to access the HD which caused the CNC to go off in areas it wasn't meant to be.

One more issue that I can think of. Make sure everything is properly grounded! This will cause all sorts of strange issues.
John
Maker of Chips
User avatar
highpockets
Vectric Wizard
 
Posts: 1282
Joined: Tue Jan 06, 2015 4:04 pm
Model of CNC Machine: PDJ Pilot Pro

Re: Problem with a program.

Postby DMcDonald » Thu May 11, 2017 4:46 am

The controller for the cnc is just for the machine. It is a Laguna Smartshop2. Only use the laptop for writing the programs then transfer with a usb. Yes I ran this program and it ran correctly then it did this redid the program and no further problems.
DMcDonald
Vectric Apprentice
 
Posts: 33
Joined: Tue Sep 29, 2015 5:47 am
Location: Melbourne Florida
Model of CNC Machine: Laguna Smartshop2

Re: Problem with a program.

Postby zeeway » Thu May 11, 2017 11:05 am

Not clear on your description - but if you are running straight from the usb, this could be the issue. I always copy the file from the usb to the computer running my machine. Also,my machine computer has been cleaned of any program that interrupts.
User avatar
zeeway
Vectric Wizard
 
Posts: 3157
Joined: Thu Feb 11, 2010 9:24 pm
Location: SC, USA
Model of CNC Machine: Self-built

Re: Problem with a program.

Postby DMcDonald » Thu May 11, 2017 12:29 pm

The computer that controls the cnc is dedicated to the cnc. The only thing on it is a few programs that get ran all the time. I use the usb to transfer from the laptop to the cnc.
DMcDonald
Vectric Apprentice
 
Posts: 33
Joined: Tue Sep 29, 2015 5:47 am
Location: Melbourne Florida
Model of CNC Machine: Laguna Smartshop2

Re: Problem with a program.

Postby Adrian » Thu May 11, 2017 12:34 pm

Are you running directly off the USB though or are you copying the file to the CNC computer hard drive and running it from there?
User avatar
Adrian
Vectric Archimage
 
Posts: 7422
Joined: Thu Nov 23, 2006 2:19 pm
Location: Surrey, UK
Model of CNC Machine: ShopBot PRS Alpha 96x48

Re: Problem with a program.

Postby DMcDonald » Thu May 11, 2017 5:27 pm

Yes copying it to the cnc computer. The laguna has a computer that is dedicated to running the cnc. It does not run the vectric program. It only has the prg. in it.
DMcDonald
Vectric Apprentice
 
Posts: 33
Joined: Tue Sep 29, 2015 5:47 am
Location: Melbourne Florida
Model of CNC Machine: Laguna Smartshop2

Re: Problem with a program.

Postby TReischl » Fri May 12, 2017 3:33 pm

Let's step back and think a moment here. . . .

You ran the program at least once, and it ran correctly.

This is a program that is in the control's memory. It does not get downloaded from the USB each time it runs.

Here is where the thinking comes in. If the program ran one time correctly, then either you have some electrical issues or the control is having its memory corrupted. Having been around computers for just about forever, it is very rare that memory suddenly goes corrupt. Yes, yes, it can happen but the probability is infinitesimal.

There is a tendency to point the finger at whatever the operator does not understand. Usually that is the programming if they cannot read g code. It is all a big huge mystery to them so it MUST be the program!

I would bet dollars to donuts you have electrical or mechanical problems, not software issues.
http://www.tedreischl.com

Low Profile CNC Router Vise
User avatar
TReischl
Vectric Wizard
 
Posts: 1966
Joined: Thu Jan 18, 2007 6:04 pm
Location: Leland NC
Model of CNC Machine: 8020 Build 48X36X8 RP 2010 Screenset

Next

Return to Hardware related questions

Who is online

Users browsing this forum: No registered users and 5 guests