programming error E-702 on AXYZ 5010 router

This forum is for general discussion regarding VCarve Pro

programming error E-702 on AXYZ 5010 router

Postby gwrosen » Mon Jan 28, 2019 5:05 pm

We’ve got a 5010 router and we generate a DXF file with Autodesk Inventor and program in VCarve Pro 6.0.
Recently, we changed to Autodesk Inventor 2019.

Now tried to route a part and got error code E-702, T-1 NOT MAPPED.

Attached is copy of my VCarve file that gives me the error.

Any ideas?

Thanks, Greg
Attachments
.33 model 3P544 REV A.crv
(67.5 KiB) Downloaded 42 times
gwrosen
Vectric Apprentice
 
Posts: 4
Joined: Fri Aug 25, 2017 6:50 pm
Model of CNC Machine: AXYZ Router

Re: programming error E-702 on AXYZ 5010 router

Postby CharlieP » Mon Jan 28, 2019 5:28 pm

Hello Greg.

What does your AXYZ User Manual say this error means, and how does it suggest resolving it?
CharlieP
Vectric Staff
 
Posts: 130
Joined: Wed Jun 04, 2014 10:25 am
Model of CNC Machine: N/A

Re: programming error E-702 on AXYZ 5010 router

Postby Adrian » Mon Jan 28, 2019 6:31 pm

From the AXYZ support site:- https://www.axyz.co.uk/fault-recovery-en/
702 TC Error Not Mapped
This is an operator or file error. There is nothing wrong with the machine. Do not service or replace
any parts.
This error occurs when a tool number is specified that has not been previously set up as a tool. Only
tools that have been set up in Tool set up can be used by the machine or by a job running on the
machine.
If the specified tool is required go to the SetupGUI or Tool Setup application to set up the tool.
Your activity log will record exactly where the error occurred if it occurring inside of a file.


You're using tool number 1 for the drill and tool number 3 for the endmill in your VCarve file. You have to map those in your AXYZ control software by the sound of it.
User avatar
Adrian
Vectric Archimage
 
Posts: 9582
Joined: Thu Nov 23, 2006 2:19 pm
Location: Surrey, UK
Model of CNC Machine: ShopBot PRS Alpha 96x48

Re: programming error E-702 on AXYZ 5010 router

Postby gwrosen » Mon Feb 11, 2019 6:39 pm

Adrian, Tool 1 = Drill and Tool 3 = end mill as you had said. From what I can see, all previous VCarve router programs use those tool number designations and never had a problem in past 3 years. We changed to Inventor 2019 in Jan 1 and ever since won't do drill (#1) OR route holes with end mill (#3). I made sure to save DXF as 2007 version and it then ran the profile operation (#3) but not pocket operation. You still think we need t odo the set-up as you'd mentioned? Thanks, Greg
gwrosen
Vectric Apprentice
 
Posts: 4
Joined: Fri Aug 25, 2017 6:50 pm
Model of CNC Machine: AXYZ Router

Re: programming error E-702 on AXYZ 5010 router

Postby Adrian » Mon Feb 11, 2019 7:08 pm

No idea, I'm just going by what the error message says. It's basically saying that you've given it tool number 3 and it has no idea what tool number 3 is so there should be somewhere in the AXYZ software where you can tell it.
User avatar
Adrian
Vectric Archimage
 
Posts: 9582
Joined: Thu Nov 23, 2006 2:19 pm
Location: Surrey, UK
Model of CNC Machine: ShopBot PRS Alpha 96x48

Re: programming error E-702 on AXYZ 5010 router

Postby adze_cnc » Mon Feb 11, 2019 8:33 pm

I'd say that the change to Inventor 2019 for DXF creation (and use of 2007 for export) is a red herring. VCarve neither knows nor cares what created the vectors. Nor is there any link between what created the DXF file and the tool mapping in the AXYZ control.

Try running a job that previously worked (in the air without material) and I expect you'll get the same error. That is, a problem with tool #1 (T-1 in the error).

Are you using an automatic tool changer (ATC)? As we have an ATC I never use the "Tools Manager" program so I can't really help with that.
User avatar
adze_cnc
Vectric Apprentice
 
Posts: 713
Joined: Sat Jul 27, 2013 10:08 pm
Location: Vancouver, BC, Canada
Model of CNC Machine: AXYZ 4008


Return to VCarve - General

Who is online

Users browsing this forum: stephenr and 27 guests